ДжоннСина
13.11.2020 00:32

1.напишите программу, которая вводит два вещественных числа, x и y , и вычисляет значение x^y . 2.напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . только на с++.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
stebone
30.11.2021 11:48
1000 = 2^3*1 + 2^2*0 + 2^1*0 + 2^0*0 = 8 + 0 + 0 + 0 = 8
0001 = 2^3*0 + 2^2*0 + 2^1*0 + 2^0*1 = 0 + 0 + 0 + 1 = 1
0110 = 2^3*0 + 2^2*1 + 2^1*1 + 2^0*0 = 0 + 4 + 2 + 0 = 6
0001 = 2^3*0 + 2^2*0 + 2^1*0 + 2^0*1 = 0 + 0 + 0 + 1 = 1
0101 = 2^3*0 + 2^2*1 + 2^1*0 + 2^0*1 = 0 + 4 + 0 + 1 = 5
0100 = 2^3*0 + 2^2*1 + 2^1*0 + 2^0*0 = 0 + 4 + 0 + 0 = 4
1001 = 2^3*1 + 2^2*0 + 2^1*0 + 2^0*1 = 8 + 0 + 0 + 1 = 9

Если это одно большое число, то вот так

1000000101100001010101001001 = 2^27*1 + 2^26*0 + 2^25*0 + 2^24*0 + 2^23*0 + 2^22*0 + 2^21*0 + 2^20*1 + 2^19*0 + 2^18*1 + 2^17*1 + 2^16*0 + 2^15*0 + 2^14*0 + 2^13*0 + 2^12*1 + 2^11*0 + 2^10*1 + 2^9*0 + 2^8*1 + 2^7*0 + 2^6*1 + 2^5*0 + 2^4*0 + 2^3*1 + 2^2*0 + 2^1*0 + 20*1 = 134217728 + 0 + 0 + 0 + 0 + 0 + 0 + 1048576 + 0 + 262144 + 131072 + 0 + 0 + 0 + 0 + 4096 + 0 + 1024 + 0 + 256 + 0 + 64 + 0 + 0 + 8 + 0 + 0 + 1 = 135664969

^ - Возведение в степень
0,0(0 оценок)
Ответ:
ХАМЕЧОКЕ2036
30.11.2021 11:48
1)var n,k: integer; begin   write('число:   ');   readln(n);   k: =0;   repeat     k: =k*10+n mod 10;     n: =n div 10;   until n=0;   writeln('новое число:   ',k); end. 2) var n,k,m: integer; begin  write('двоичное число:   ');   readln(n);   k: =1;   m: =0;   repeat    m: =m+k*(n mod 10);     n: =n div 10;     k: =k*2;   until n=0;   writeln('десятичное число:   ',m); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота