svet0chka
31.07.2020 19:58

Составить программу к следующей . задан случайным образом одномерный массив из n действительных чисел в диапазоне от -10 до 50. подсчитать сколько в нем элементов больше (10).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
лсоаоа
09.10.2020 20:29

Код будет работать в Pascal ABC

(в остальных программах нужно поменять функцию рандома чисел)


program p1;

var  

  //Пусть массив будет состоять из 50 элементов

  n:array[1..50] of integer;

  i, j, s:integer;

begin

   

  //Создание массива случайный чисел от -10 до 50

  for i:= 1 to 50 do

    begin

       n[i]:= random(-10, 50);

       writeln(n[i]);

    end;

     

     //Подсчет  

     for j:= 1 to 50 do

       begin

          if n[j] > 10 then

            begin

              s:=s+1;

            end;

       end;

     

    WriteLn('Элементов больше 10: ', s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота