ByArts1000
18.05.2021 21:55

Напишите программу получения всех совершенных чисел из диапазона от 1 до написать через цикл while.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
doge232
09.10.2020 19:51

var n,i,j,s,k:integer;

begin

write('Введите число: ');

readln(n);

i:=1;

while i <= n do  

begin

j:=1;

s:=0;

while j<i

do

if i mod j = 0 then

begin

s:=s+j;

j:=j+1;

end

else

j:=j+1;

if s=i then

begin

k:=k+1;

if k=1 then write('Совершенные числа из диапазона от 1 до ',n,': ');

write(i,'  ')

end;

i:=i+1

end;

if k=0 then write('Совершенных чисел в диапазоне от 1 до ',n,' нет');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота