t11o
20.02.2020 13:41

Нужно написать программу в паскале возвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число r.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
TDashaS
27.08.2020 12:47

var

 r, i: integer;

 

begin

 readln(r);

 for i := 0 to r do write(power(i, 2), ' ');

end.

0,0(0 оценок)
Ответ:
Levix322
27.08.2020 12:47

const n=10;

var a:array[1..n] of integer;

i,r: integer;

begin

write (' Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write (a[i]:3,' ')

end;

writeln;

write ('Введите число: ');

readln (r);

write ('Преобразованый массив: ');

for i:=1 to n do

begin

if abs(a[i]) <= r then a[i]:=a[i]*a[i];

write (a[i]:3,' ')

end

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота