Grayr2005
16.01.2021 22:32

Задано целое число n написать программу которая находит количество 0 в заданном числе

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sainegorova201
09.10.2020 19:37

//PascalABC.NET v3.3 1633

begin

 var num:=ReadInteger('Введите число: ');

 var sum:=0;

 for var i:=1 to IntToStr(num).Length do

   if IntToStr(num)[i] = '0' then sum += 1;

 writeln('Количество нулей: '+sum);

end.

0,0(0 оценок)
Ответ:
ZORaSsa
09.10.2020 19:37
Java:

Scanner in = new Scanner();
String data = in.nextLine();
int counter =0;
for(char g:data.toCharArray()){
if('0'.equals(g)){
counter++;
}
}
System.out.println(counter);
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота