KSUmaUYouTobe
12.02.2023 09:22

Написать программу осуществляющую поиск в одномерном массиве a, состоящего из 20 элементов, заданных случайным образом элемента, равного 50. если такого нет, вывести на экран сообщение “такого нет”.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Marymol2005
09.10.2020 19:25

var a:array[1..20] of integer;

i,k: integer;

begin

for i:=1 to 20 do

begin

a[i]:=random(51)+25;

write (a[i],' ')

end;

writeln;

for i:=1 to 20 do

if a[i]=50 then

begin

writeln (i,' элемент = ',a[i]);

k:=k+1

end;

if k=0 then writeln ('Такого нет')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота