NetBPeMeHu
07.04.2023 17:19

Составьте программу которая формирует массив из пятнадцати случайных чисел от -20 до 20 и увеличивает в два раза числа кратные пяти, а остальные уменьшает в два раза

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
anyr04
09.10.2020 19:05

const n=15;

var a:array [1..n] of integer;

b:array [1..n] of real;

i:integer;

begin

write('       Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write(a[i]:5);

if a[i] mod 5 = 0 then b[i]:=a[i]*2

else b[i]:=a[i]/2

end;

writeln;

write('Преобразованный массив: ');

for i:=1 to n do write(b[i]:5);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота