girb13
15.01.2023 09:54

Напишите программу, находящую сумму нечетных цифр числа x в питоне

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Elizabeth191102
09.10.2020 19:02

x = int (input()) #ввод х, х - целое число

s = 0 #переменная для суммы

if x == 0:

   print(s) #если х - нулевой, то сумма нечетных цифр равна 0

else:

   while x != 0:  #начинаем цикл поиска цифр

       c = x%10 # "отрезаем" от х последнюю цифру и записываем в переменную с

       if c != 0 and c%2 != 0:  #если цифра с делится на 2 с остатком, то она нечетная

           s = s + c #тогда мы ее прибавляем к s

       x = x // 10 #"отрезаем" от х последнюю цифру, а оставшееся число записываем в х

   print(s)

           

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота