ученик1890
23.11.2022 14:59

Написать программу на c# "произвести суммирование натуральных чисел 1, 2, пока их сумма s не станет равной или превысит величину h. вывести на экран последнее слагаемое и значение суммы."

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
wof1234
02.09.2020 17:02

Написал на c++ т,к синтаксис шарпа не знаю, можешь переделать под себя.

#include "pch.h"

#include <iostream>

using namespace std;



int main()

{

setlocale(LC_ALL, "rus");

int summa = 0;

int h;

int i = 1;

cout << "Введите h" << endl;

cin >> h;

for(i;summa<h;)

{

 summa += i;

 i++;

}

cout <<"Сумма= "<< summa << endl <<"Последнее слагаемое = "<< i - 1 << endl;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота