rasulid04
06.12.2021 17:10

Написать программу в паскале. чтобы при вводе числа, в окружности было число окружностей равное введенному (кроме центральной) на рисунке пример с 8 окружностями

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
greennattea
11.06.2020 12:49
1)
from random import random
N = 10
a = []
for i in range(N):
    b = int(random() * 50)
    a.append(b)
print(a)

min = 101
for i in range(N-1):
    s = a[i]+a[i+1]
    if (s < min) and (s % 2 == 1):
        min=s
print(min)

Пример:[41, 35, 16, 7, 29, 9, 16, 28, 10, 6]
23

2)
from random import random
N = 10
a = []
for i in range(N):
    b = int(random() * 50)-25
    a.append(b)
print(a)

k = 0
for i in range(N-1):
    p = a[i]*a[i+1]
    s = a[i]+a[i+1]
    if (p % 2 != 0) and (s > 0):
        k = k+1
print(k)

Пример:[11, 23, 12, -16, 21, 15, -11, -10, 10, 17]
3
0,0(0 оценок)
Ответ:
Kember
02.11.2022 02:53
//Описание добавить не вышло на сайт, посему - в файле

#include "stdafx.h"
#include <conio.h>

void swap(short &a, short &b) {
    short c = a;
    a = b;

    b = c;
}

void sort(short &a, short &b, short &c)
{
    short min = a,
        max = c;
    if (min > b) min = b;
    if (min > c) min = c;
    if (max < a) max = a;
    if (max < b) max = b;
    b = a + b + c - min - max;
    a = min;
    c = max;
}

int main()
{
    short a1, b1, c1, a2, b2, c2;
    scanf_s("%hd %hd %hd", &a1, &b1, &c1);
    scanf_s("%hd %hd %hd", &a2, &b2, &c2);

    sort(a1, b1, c1);
    sort(a2, b2, c2);

    if ((a1 == a2) && (b1 == b2) && (c1 == c2))
        printf("Boxes are equal");
    else
        if ((a1 <= a2) && (b1 <= b2) && (c1 <= c2))
            printf_s("The first box is smaller than the second one");
        else
            if ((a2 <= a1) && (b2 <= b1) && (c2 <= c1))
                printf_s("The first box is larger than the second one");
            else
                printf_s("Boxes are incomparable");

    _getch();
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота