davideblan33
28.04.2023 22:18

Составьте программу которая формирует массив из 10 случайных чисел в диапазоне от 1 до 10 и вычисляет произведения элементов массива с нечестными значениями. на экран выводится исходный массив, массив с нечестными значениями и произведение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Rednegel
09.10.2020 15:48

program fantscrin;



 const n = 10;



 var a: array [1..n] of integer;

     i,s:integer;

Begin

 for i:=1 to n do

   a[i]:= random(11)+1;

 for i:=1 to n do

   write(a[i], '  ');

 p:=1;

 for i:=1 to n do

   if (i mod 2 <> 0) then

                              begin

                                p:=p*a[i];

                                write(a[i], '  ');

                               end;

 writeln('');

 writeln('Произведение = ',p);

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота