tumenka140
10.12.2021 16:37

Составить программу по которой заполняется массив а [1..30] случайным образом символами алфавита (по кодовой таблице от a до z), а на экран потом выводятся только буквы из этого массива, стоящие до буквы g.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
знайка208
09.10.2020 14:25

program abc;

var a:array[1..30] of integer;

i:integer;

begin

Randomize;

a[1]:= 65+ random (25);

for i:=2 to 30 do  

begin

if (a[i-1]=75) or (a[i-1]=0) then  a[i]:=0 else a[i]:= 65+ random (25);

if a[i]>0 then write (chr(a[i]),' ');

end;

end.

в таблице ASCII символ G - 75 по номеру , а диапазон алфавита от 65 до 90

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота