vaniagaclyc
16.08.2022 01:59

Нужна ! с операторов div и mod написать программу в паскале. на вход- трехзначное число. на выход- вывести на экран количество сотен, десятков и единиц в этом числе.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Matka2002
09.10.2020 14:15

Program N1;

var a,c1,c2,c3: integer;

begin

 writeln('Введите число');

 read(a);

 c1:=a mod 10;

 c2:=(a div 10) mod 10;

 c3:=(a div 100) mod 10;

 writeln('Кол-во сотен = ',c3);

 writeln('Кол-во десятков = ',c2);

 writeln('Кол-во единиц = ',c1);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота