07.06.2022 05:55

Написать программу: упорядочьте элементы строк массива по убыванию модулей элементов методом двоичного включения (pascal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aylinlove
17.08.2020 07:18

#include <iostream>

#include <algorithm>

#include <vector>

#include <random>

 

int main()

{

 srand(time(NULL));

 const int n = 20;

 std::vector<int> arr(n);

 for(int i = 0;i < n;i++)

 {

     arr[i] = -20 + rand() % 40;

 }

 

 for(const int i : arr)

 {

     std::cout << i << " ";

 }

 std::cout << std::endl;

 

 std::sort(arr.begin(),arr.end(),[](int a,int b){ return abs(a) > abs(b); });

 for(const int i : arr)

 {

     std::cout << i << " ";

 }

 

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота