ванька68
31.07.2021 03:36

Составьте программу,которая формирует массив из шестнадцати случайных целых чисел от-20 до 20 и находит индексы четных элементов;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SashaPolishuk
09.10.2020 13:33

Program ABC;

uses crt;

var

  a:array[1..16] of integer;

  k,i,n:integer;

begin

randomize;

for i:=1 to 16 do

   begin

   a[i]:=random(41)-20;

   write(a[i],' ');

   end;

writeln;

for i:=1 to 16 do begin if (a[i] mod 2=0) and (a[i]<>0) then write(i,' '); if a[i]<0 then k:=k+1 end;

writeln;

end.

0,0(0 оценок)
Ответ:
drakonchik5005
09.10.2020 13:33

begin

 var a := ArrRandom(16, -20, 20); a.Println;

 a.Numerate(0).Where(x -> x[1].isEven)

 .Select(x -> x[0]).Println;

end.


Составьте программу,которая формирует массив из шестнадцати случайных целых чисел от-20 до 20 и нахо
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота