Dashaass554
23.06.2022 23:33

Можете написать программу выводящую на экран строку матрицы сумма элементов в которой максимальна на python

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
TonyX2
27.08.2020 12:00

import random as r

def function(n, m):

   matrix = [[r.randint(0, 100) for x in range(n)] for y in range(m)]

   max_sum = []

   for q in matrix:

       max_sum.append(sum(q))

       print("{} -- {}".format(q, sum(q)))

   id_max_el = max_sum.index(max(max_sum))

   print(

       "\nСтрока матрицы сумма элементов в которой максимальна -- {}".format(

           matrix[id_max_el]))

z = int(input("Сколька столбцов?: "))

c = int(input("Сколька строк?: "))

function(z, c)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота