lol09890
01.09.2022 09:45

Нужен код на с++! : напишите программу, которая удваивает все буквы "z" в строке (нужно, чтоб строка изначально вводилась с клавиатуры) пример: было (zozo) стало (zzozzo)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikitkaandreev1
09.10.2020 12:54

Держи -_-

#include <iostream>

#include <string>

using namespace std;

int main()

{

   string a;

   cin>>a;

   for(unsigned j=0;j<a.length();j++){

       if (a[j]=='z')  a.insert(++j,"z");

       

   }

   cout<<a;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота