wwwzelenruowzl2z
05.10.2021 08:54

Напишите программу, которая определяет, сколько раз встречается в матрице элемент, равный k .

входные данные
в первой строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по m натуральных чисел, разделённых пробелами. в следующей строке записано целое число k .

выходные данные
программа должна вывести количество элементов матрицы, равных k
входные данные
4 5
1 2 3 4 5
6 12 8 9 10
11 12 12 14 15
16 17 18 12 20
12
выходные данные
4
c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivinaKiyn
02.10.2019 21:20

ответ:

оба утверждения верны

0,0(0 оценок)
Ответ:
BigD13
18.01.2024 19:55
Школьная программа, предлагающая решение данной задачи на языке C++, может выглядеть следующим образом:

```cpp
#include
using namespace std;

int main() {
// Ввод размеров матрицы
int n, m;
cin >> n >> m;

// Создание матрицы
int matrix[n][m];

// Ввод элементов матрицы
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
cin >> matrix[i][j];
}
}

// Ввод числа k
int k;
cin >> k;

// Подсчет количества элементов, равных k
int count = 0;
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
if (matrix[i][j] == k) {
count++;
}
}
}

// Вывод результата
cout << count << endl;

return 0;
}
```

Давайте разберем код пошагово:

1. Ввод размеров матрицы.
```cpp
int n, m;
cin >> n >> m;
```
Здесь мы используем переменные `n` и `m` для хранения количества строк и столбцов матрицы соответственно.

2. Создание матрицы.
```cpp
int matrix[n][m];
```
Мы создаем двумерный массив `matrix`, размер которого зависит от введенных значений `n` и `m`.

3. Ввод элементов матрицы.
```cpp
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
cin >> matrix[i][j];
}
}
```
Мы используем два цикла `for`, чтобы пройти по всем элементам матрицы и заполнить их значениями, введенными пользователем.

4. Ввод числа `k`.
```cpp
int k;
cin >> k;
```
Мы используем переменную `k` для хранения числа, которое нужно найти в матрице.

5. Подсчет количества элементов, равных `k`.
```cpp
int count = 0;
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
if (matrix[i][j] == k) {
count++;
}
}
}
```
Мы используем два цикла `for`, чтобы пройти по всем элементам матрицы и сравнить их с числом `k`. Если элемент равен `k`, мы увеличиваем счетчик `count` на 1.

6. Вывод результата.
```cpp
cout << count << endl;
```
Мы выводим значение счетчика `count`, представляющего количество элементов, равных `k`.

Таким образом, данная программа позволит определить количество раз, которое число `k` встречается в заданной матрице.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота