aibek6707
18.03.2021 21:33

Составьте программу на языке паскаль для решения квадратного уравнения с разветлением

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olqa252ru
22.01.2021 19:42
Школьный обед - меню (список блюд с ценой), сколько человек подписаны на бесплатный/комплексный обед, какой объем блюд нужно приготовить к обеду, время обеда и тд

Ремонт квартиры - какие изменение необходимо сделать, бюджет, кто будет делать, материалы и их приобретение, инструменты, рассчетное время ремонта и тд

Пассажир поезда - имя, место, билет, постель, чай, спутники, багаж, от куда и куда, поезд и вагон

Дом, в котором ты живешь -  адрес, этажность, материал стен, коммуникации, год сдачи, кол-во подьездов и тп
0,0(0 оценок)
Ответ:
Lenaclati
23.07.2022 19:41
Type
  Point=record
    x,y:real
    end;

procedure GetPoint(c:char; var A:Point);
  var
    x,y:real;
begin
  Write('Введите координаты x и y точки ',c,': ');
  Read(x,y);
  A.x:=x; A.y:=y
end;

function DistPoint(A,B:Point):real;
begin
  DistPoint:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;

var
  A,B,M:Point;
  d,p,ab,ma,mb:real;
begin
  GetPoint('A',A); GetPoint('B',B); GetPoint('M',M);
  ab:=DistPoint(A,B); ma:=DistPoint(M,A); mb:=DistPoint(M,B);
  if ma>=ab+mb then d:=mb
  else
    if mb>=ma+ab then d:=ma
    else begin
      p:=(ma+mb+ab)/2;
      d:=2*sqrt(p*(p-ab)*(p-ma)*(p-mb))/ab
    end;
  Writeln('Минимальное расстояние составляет ',d)
end.

Тестовое решение:
Введите координаты x и y точки A: -3 -5
Введите координаты x и y точки B: 2 5
Введите координаты x и y точки M: -3 4
Минимальное расстояние составляет 4.02492235949962
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота