marina03501997
07.06.2023 01:03

На с++ с циклом white на вход программы подается 10 чисел. выведите в столбик для каждого из них число, равное удвоенному квадрату первоначального числа. формат входных данных в единственной строке через пробел вводятся 10 целых чисел, по модулю не превосходящих 1000. формат выходных данных необходимо вывести 10 строк, в каждой из которых будет по одному числу — результат преобразования исходных чисел. примеры входные данные выходные данные 1 10 2 4 2 5 3 6 101 11 2 200 8 32 8 50 18 72 20402 242

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elenakopylova7
09.10.2020 11:57
Прикреплена фотография с кодом, тест и сам кодОткрывать любым текстовым редактором
На с++ с циклом white на вход программы подается 10 чисел. выведите в столбик для каждого из них чис
На с++ с циклом white на вход программы подается 10 чисел. выведите в столбик для каждого из них чис
0,0(0 оценок)
Ответ:
ninbondar100164
09.10.2020 11:57
Решение с массивами

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a[10];

   int i = 0;

   while (i < 10) {

     cin >> a[i];

     ++i;

   }

   i = 0;

   while (i < 10) {

     cout << (2 * a[i] * a[i]) << endl;

     ++i;

   }

   return 0;

}


Решение без массивов (онлайн-вывод)

#include <bits/stdc++.h>

using namespace std;

int main() {

   int x;

   int i = 0;

   while (i < 10) {

     cin >> x;

     cout << (2 * x * x) << endl;

     ++i;

   }

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота