Ganster1234567
10.09.2022 10:50

Определите вес рюкзака и входные данные программа получает на вход три целых положительных числа. первое число r - максимально разрешенный вес рюкзака. второе число к - количество предметов. число r не превосходят 1, число к не превосходит 100,

выходные данные выходные данные должны содержать два числа - вес рюкзака и вес чемодана (вес

пустого рюкзака и чемодана не учитываются).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
румия2408
06.11.2021 14:28
Const
    max_length = 10;

type
    arr = array [0..max_length, 0..max_length] of byte;

var
    a: arr;
    i, j, n, m, k, x, y: byte;
    c: char;
    f: text;

//procedure PrintMatrix(a: arr);
//begin
//    for var i := 0 to max_length do
//    begin
//        writeln;
//        for var j := 0 to max_length do
//            write(a[i, j], ' ');
//    end;
//    writeln;
//end;

procedure labirint(i, j: byte);
begin
    if (i <= n) and (i >= 0) and (j <= m) and (j >= 0) and (a[i, j] = 0) then begin
        a[i, j] := 1;
        k := k + 1;
        labirint(i, j - 1);
        labirint(i, j + 1);
        labirint(i - 1, j);
        labirint(i + 1, j);
    end;
end;

begin
    Assign(f, 'input.txt');
    Reset(f);
    
    readln(f, n, m);
    for i := 0 to n do
    begin
        for j := 0 to m do
        begin
            read(f, c);
            case c of
                'x': a[i, j] := 2;
                '.': a[i, j] := 0;
                '+':
                    begin
                        x := i;
                        y := j;
                        a[i, j] := 0;
                    end;
            end;
        end;
        readln(f);
    end;
    Close(f);
    
//    PrintMatrix(a);
    
    labirint(x, y);
    writeln(k);
//    PrintMatrix(a);
end.
0,0(0 оценок)
Ответ:
Sasha808621
30.03.2020 06:11
//Dev-C++ 5.11

#include <iostream>
#include <string>
using namespace std;

void DeleteStr(string&, int, int);

int main(void)
 {string s;
 int n,l;
 cin>>s>>n>>l;
 DeleteStr(s,n,l);
 cout<<s<<endl;
 return 0;}

void DeleteStr(string &s, int n, int l)
 {for(int i=n;i<s.length();i++) //начинаем удаление с n элемента
 if(i+l<s.length())  //проверка не выходит ли смещение за границы строки
  s[i]=s[i+l];   //если не выходит, просто переносим символ с позиции+l
 else
   s[i]='\0';      //иначе вводим на позицию пустой символ
}

Пример ввода:
Caster 1 4
Пример вывода:
Cr
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота