ashurovaalbina8
28.05.2023 04:01

Написать программу паскаль с клавиатуры вводится три числа- коэффициент квадратного уравнения. сколько решений имеет уравнение !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lera310520069
09.10.2020 11:34

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25



var

 a,b,c: integer;

 x,d: real;

begin

 repeat

   write('Введите коэффициент a (a<>0): ');

   readln(a);

 until a<>0;

 write('Введите коэффициент b: ');

 readln(b);

 write('Введите коэффициент c: ');

 readln(c);

 d:=b*b-4*a*c;

 writeln('Решение уравнения:');

 if d=0 then

   writeln('Корень один: х = ',-b/2/a) else

 if d<0 then

   writeln('Корней на множестве действительных чисел нет') else  

 begin

   writeln('Корней два:');

   writeln('1-й корень: x1 = ',(-b-sqrt(d))/2/a);

   writeln('2-й корень: x1 = ',(-b+sqrt(d))/2/a);

 end;

 readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота