kolart
01.07.2020 14:50

Hel//helllppp написать программу в паскаль, . в массиве a[1..6] найти сумму положительных элементов, найти сумму положительных элементов, которые которые находятся в диапазоне от -1 до 5 включительно.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
trahtrah1
09.10.2020 11:22
PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(6, -10, 10);

 a.Println;

 Writeln('Сумма положительных ', a.Where(t -> t > 0).Sum);

 Writeln('Сумма положительных на [-1;5] ',

   a.Where(t -> (t > 0) and t.InRange(-1, 5)).Sum);

end.

Пример3 -2 -2 7 3 6Сумма положительных 19Сумма положительных на [-1;5] 6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота