malorodnovapoli
25.03.2021 13:56

C++ code blocks напишите программу, которая в последовательнсти целых чисел определяет количество нечетных чисел, кратных 3. программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введеные числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.c

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ragmova
09.10.2020 11:12
#include <iostream>
using namespace std;

int main() {
int k = 0;
int n = 0;
int x;
do {
cin >> x;
if (x != 0) {
++n;
if (x % 2 == 1 && x % 3 == 0) ++k;
}
} while (x != 0);
cout << n << " " << k << endl;
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота