Vladimir1023456789
03.12.2021 13:16

Напишите программу,которая a)выводит на экран один двухмерный массив(5*3),в котором вписаны целые числа в интервале от 50 до 100; b)в массиве находится клетка с наименьшим значением.показывает на экране.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
135790246anna
09.10.2020 11:12

const n=5; m=3;


var a:array [1..n,1..m] of integer;


i,j,e:integer;


begin


for i:= 1 to n do


begin


for j:=1 to m do


begin


a[i,j]:=Random(51)+50;


write(a[i,j]:4)


end;


writeln;


end;


e:=a[1,1];


for i:= 1 to n do


for j:=1 to m do


if a[i,j]<e then e:=a[i,j];


writeln ('Наименьший элемент: ',e)


end.

0,0(0 оценок)
Ответ:
xmistick
09.10.2020 11:12
PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := MatrRandom(5, 3, 50, 100);

 a.Println(4);

 var (p, i, j) := a.ElementsWithIndexes.MinBy(t -> t[0]);

 Writeln('Минимальный элемент a[', i + 1, ',', j + 1, ']=', p);

end.

Пример

 64  54  96  76  96  59  68  95  63  78  51  75  68  56 100Минимальный элемент a[4,2]=51
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота