yxhcycgc
10.06.2022 04:51

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел кратных 8 из интервала [121, 400], а если таких чисел нет, то ввести no. решить через массив.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nadezdaakopan
21.08.2020 20:21

var n,i,s,k:integer;

a:array [1..1000] of integer;

begin

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число: ');

readln (a[i]);

if (a[i] mod 8 = 0) and (a[i]>=121) and (a[i]<=400) then

begin

s:=s+a[i];

k:=k+1

end

end;

if k=0 then write ('NO')

else writeln ('Cреднее арифметическое чисел кратных 8 из интервала [121, 400]  равно: ',s/k:0:3)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота