Anny2107
17.02.2020 14:49

Дан целочисленный массив а[n]. заменить все элементы массива, являющиеся простыми числами, на максимальное значение элементов массива. написать программу на с++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
violagugu
09.10.2020 10:38

#include <bits/stdc++.h>

using namespace std;

int n,a,mx = -1e6,b[10101];

bool check(int x) {

for (int i = 2; i <= sqrt(x); i++)

 if (x % i == 0) return 0;

return 1;

}

main () {

cin >>n;

for (int i = 1; i <= n; i++)

{

 cin >>b[i];

 mx = max(mx,b[i]);

}

for (int i = 1; i <= n; i++)

 if (check(b[i])) b[i] = mx;

for (int i = 1; i <= n; i++)

 cout <<b[i] <<" ";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота