marinandnatasha1
02.05.2020 20:10

Напишите программу, которая заполняет массив случайными числами на отрезке [-2; 2] и считает сумму положительных элементов массива. (паскаль 9 класс)
типо этого

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Asig
04.01.2024 13:21
Конечно! Для решения данной задачи, мы можем использовать следующий алгоритм:

1. Объявляем переменные:
- n - размер массива (количество элементов)
- sum - переменная для хранения суммы положительных элементов массива
- array - массив для хранения случайных чисел

2. Вводим значение переменной n. Например, n = 10.

3. Создаем массив array размером n.

4. Заполняем массив случайными числами на отрезке [-2; 2]:
- Для каждого элемента array[i], где i от 0 до n-1, выполняем следующие действия:
- Генерируем случайное дробное число x на отрезке [0; 1] с помощью функции Rand.
- Переопределяем значение элемента array[i] следующим образом:
- Если x меньше 0.5, тогда присваиваем значение элемента -2.
- Если x больше или равно 0.5, тогда присваиваем значение элемента 2.

5. Выводим массив array на экран для проверки.

6. Считаем сумму положительных элементов массива:
- Для каждого элемента array[i], где i от 0 до n-1, выполняем следующие действия:
- Если array[i] больше 0, тогда добавляем его к переменной sum.

7. Выводим значение переменной sum на экран.

Вот полная программа на языке Паскаль для решения данной задачи:

```
program SumOfPositiveElements;

var
n, i: integer;
sum: real;
array: array of real;

begin
// Шаг 2
write('Введите размер массива: ');
readln(n);

// Шаг 3
SetLength(array, n);

// Шаг 4
for i := 0 to n-1 do
begin
// Шаг 5
array[i] := -2 + Random * 4;
end;

// Шаг 5
writeln('Массив array:');
for i := 0 to n-1 do
begin
write(array[i]:4:2, ' ');
end;
writeln;

// Шаг 6
sum := 0;
for i := 0 to n-1 do
begin
if array[i] > 0 then
begin
sum := sum + array[i];
end;
end;

// Шаг 7
writeln('Сумма положительных элементов массива: ', sum:4:2);

end.
```

Эта программа считает сумму положительных элементов массива, заполненного случайными числами на отрезке [-2; 2]. Она использует генератор случайных чисел, функцию SetLength для создания массива определенного размера и циклы для заполнения массива и подсчета суммы положительных чисел. В конечном итоге, программа выводит на экран массив и сумму положительных элементов.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота