12abgh
07.05.2020 07:32

На python. во введённой строке определите количество слов, являющихся корректной запи-

сью шестнадцатеричных чисел (то есть слова вида «10», «1f» и т. переведите

эти числа в десятичную систему и выведите преобразованную строку.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KaKOYTAGHOM
15.04.2022 18:15
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
0,0(0 оценок)
Ответ:
12abgh
20.03.2022 17:38
Запомни: в 1 байте 8 бит, в 1 Кбайте 1024 байт, 1 Мегабайте = 1024 кбайт, 1 Гигабайт = 1024 мегабайт.
Исходя из этого имеем (приведём всё к битам):
1) 5 бит
2) 15 байт = 15*8 бит = 120 бит
3) 1024 килобайт = 1024*1024 байт = 1048576 байт = 1048576 *  8 бит = 8388608 бит
4) 1024 мегабайт = 1024*1024*1024*8 бит = 8589934592 бит
5) 15 килобайт = 15*1024*8 бит = 122880 бит

Таким образом:
5 бит → 15 байт → 15 килобайт → 1024 килобайт → 1024 мегабайт

(хотя здесь и вычислять ничего не нужно - всё итак очевидно и без расчётов)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота