Dan4ik7211
16.01.2022 20:18

Написать программу, которая проверяет, образуют ли элементы введенного с клавиатуры массива неубывающую последовательность отрицательных чисел.с++.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Polinazaya02
09.10.2020 07:56
#include <iostream>

int main()
{
int length;
bool flag=true;
std::cout<<"Введите длину массива: ";
std::cin>>length;
int *array=new int[length];
for (int i=0;i<length;i++)
{
std::cin>>array[i];
if (i>0)
if (array[i-1]>array[i])
flag=false;
if (array[i]>=0)
flag=false;
}
std::cout<<(flag?"true":"false");
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота