Bogatuk2005
30.01.2020 20:04

Написать программу в с++ описать функцию otr(ax,bx,ay,by) вещественного типа находящую длину отрезка ab на плоскости по координатам его концов |ab|=sqrt((ax-bx)^2+(ay-by)^2 )(ax,ay,bx,by)- вещественны параметры) с этой функции найти длины отрезков ab,ac,ad, если с клавиатуры заданы координаты точек, a,b,c,d.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kosmikanna
09.10.2020 07:54

#include <iostream>

#include <cmath>

using namespace std;


double Otr(double Ax, double Bx, double Ay, double By) {

return sqrt((Bx - Ax)*(Bx - Ax) + (By - Ay)*(By - Ay));

}


int main() {

double Ax, Ay, Bx, By, Cx, Cy, Dx, Dy;

cin >> Ax >> Ay >> Bx >> By >> Cx >> Cy >> Dx >> Dy;

cout << "|AB|=" << Otr(Ax, Bx, Ay, By) << endl;

cout << "|AC|=" << Otr(Ax, Cx, Ay, Cy) << endl;

cout << "|AD|=" << Otr(Ax, Dx, Ay, Dy) << endl;

return 0;

}


Написать программу в с++ описать функцию otr(ax,bx,ay,by) вещественного типа находящую длину отрезка
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота