Написать программу вывода информации о том что при заданных значениях параметров a, b,c и x выполняется или не выполняется равенство ax^2+bx+c меньше нуля sharp develop
//Как-то громоздко получилось, но я так вижу. Эх, выходные. const n=5; var a:array[1..n] of integer; b:array[0..8] of integer; ar:array[1..n] of integer; i,c,j:integer; begin randomize; writeln('Array:'); for i:=1 to n do begin a[i]:=random(8); write(a[i]:4); end; for i:=1 to n do begin; for j:=0 to 8 do if a[i]=j then inc(b[j]); end; for i:=1 to n do begin; for j:=0 to 8 do if (b[j]>1) and (a[i]=j) then a[i]:=9; if a[i]<>9 then begin; inc(c); ar[c]:=a[i]; end; end; writeln; for i:=0 to 8 do writeln(i,'=',b[i]); writeln; writeln('Final array:'); for i:=1 to n do if a[i]=9 then a[i]:=0;
for i:=1 to c do begin; a[i]:=ar[i]; write(a[i]:4); end; end.
1 - моделью 2 - меньше информации 3 - глобус, макет здания, муляж яблока, манекен 4 - рисунок, фотография 5 - знаковой 6 - смешанной 7 - автомобиль — техническое описание автомобиля, город — путеводитель по городу 8 - существенные признаки объекта-оригинала 9 - разные модели объекта 10 - физическая карта, график зависимости расстояния от времени, схема узора для вязания крючком, схема метро 11 - словесное описание, формула 12 - знаковой 13 - смешанной 14 - болт — чертеж болта, мелодия — нотная запись мелодии
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку