Jackichan89
31.07.2020 07:32

Напишите программу которая отобразит числа в порядке пирамиды паскаля. программа должна вычислить и отобразить 15 этажей пирамиды с++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
daria200205
09.10.2020 07:33

#include <iostream>

#include <iomanip>

using namespace std;

#define N 15

#define S 128

int main () {

int mas[S];

for(int n = 0; n < N; n++) {

 mas[0] = 1;

 for(int i = 1; i <= n ; i++)  

  mas[i] = 0;

 for(int i = 1; i <= n; i++)

  for(int j = i; j >= 1; j--)

   mas[j] += mas[j-1];

 cout << setw(2) << n << ":";

 for(int i = 0; i < 35 - 5 * n / 2; i++)

  cout << " ";

 for(int i = 0; i <= n ; i++)

  cout << setw(5) << mas[i];

 cout << endl;

}

   return 0;

}


Напишите программу которая отобразит числа в порядке пирамиды паскаля. программа должна вычислить и
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота