Карейка0167
11.01.2021 08:30

Нужно написать программу которая при вводе координат начальной и конечной ячеек шахматной доски будет решать возможен ли ход в конечную ячейку шахматной фигуры «слон». программа должна вывести: «yes» если ход возможен и «no» если нет. решение в c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MrDeder
09.10.2020 07:33

#include <iostream>

using namespace std;

int main(){

long long x1,x2,y,y2;

 cout<<"Enter x1:";

 cin>>x1; // вводим начальную координату по горизонтали

 cout<<"Enter y1:";

 cin>>y; // вводим начальную координату по вертикали

 cout<<"Enter x2:";

 cin>>x2; // вводим конечную координату по горизонтали

 cout<<"Enter y2:";

 cin>>y2; // вводим координату координату по вертикали

if(x1 - y == x2 - y2 || x1 + y == x2 + y2){

 cout << "YES";

}

else{

 cout << "NO";

}

}


else{

 cout << "NO";

}

}

0,0(0 оценок)
Ответ:
MRSAVVA
09.10.2020 07:33

#include "stdafx.h"  

#include <iostream>  


using namespace std;  


int main()  

{  

// input data  

int x1, y1, x2, y2;  


// get data  

co

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота