olezhkash228
17.07.2020 15:48

Напишите программу в pascal сергей страдает ожирением в процессе голодании он каждую неделю скидывает 3% от предыдущего веса изначально он весил 150 кг в машину он влезет когда будет весить 96 кг через сколько недель он влезет в машину?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ddurua
09.10.2020 07:29

VAR  

MASSA:real;

NED:INTEGER;

BEGIN

MASSA:=150;

NED:=0;

WHILE (MASSA>=96) DO

BEGIN

MASSA:=MASSA-MASSA*0.03;

NED:=NED+1;

END;

WRITELN('Через ',NED,' недель Сергей влезет в машину')

END.

0,0(0 оценок)
Ответ:
PapayaS
09.10.2020 07:29

var v,z:real;

   i:integer;

begin

v:=150;

while not(v<=96) do

begin

z:=(v/100)*3;

v:=v-z;

inc(i);

end;

write(i);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота