Zomka1
16.12.2020 13:13

1)составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с нечетными значениями в три раза, а элементы с четными значениями заменяя на 0. 2)составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы.выведите на экран исходный и полученный массивы. это нужно через pascalabc. заранее огромное

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
АлiнаКукушкiна
09.10.2020 06:59
1) var a:array [1..10] of integer;
i:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
for i:=1 to 10 do begin
if (i mod 2 = 0) then a[i]:=0 else a[i]:=a[i]*3;
write(a[i],' ');
end;
readln;
end.

2) var a:array [1..10] of integer;
i,k:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
k:=a[1];
a[1]:=a[10];
a[10]:=k;
for i:=1 to 10 do write(a[i],' ');
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота