vovareket
21.04.2022 00:09

Напишите программу, которая считывает с клавиатуры одно дробное число и выводит обратное ему. если при этом введённое с клавиатуры число меньше по абсолютной величине одной миллионной (в частности, если оно равно нулю), вывести вместо этого миллион. пример ввод вывод 0.5 2.0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lenaclati
21.08.2020 19:29
Var i,x: Integer;
n: Real;
begin
x:=1;
readln(n);
if n<>0 then
begin
while frac(n)<>0 do
begin
n:=n*10;
x:=x*10;
end;
if frac(x/n)=0 then writeln(x/n) else writeln(x,'/',n);
end else
writeln('1000000');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота