Ясмина1604
27.02.2022 19:39

Вычислить сумму чисел от 1 до 100 которые делятся на 3 написать программу для вычисления(паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tom0291837465
09.10.2020 06:42
PascalABC.NET 3.4.2, сборка 1847 от 28.10.2018Внимание! Если программа не работает, обновите версию!

begin

 3.Step(3).TakeWhile(t -> t <= 100).Sum.Println

end.

1683
0,0(0 оценок)
Ответ:
Nalasinskaya
09.10.2020 06:42

2 варианта

var s,i: integer;

begin

s:=0;

i:=3;

while (i<100) do

begin

s:=s+i;

inc(i,3);

end;

writeln('Сумма чисел, которые делятся на 3: ',s);

readln;

end.

var s,i: integer;

begin

s:=0;

for i:=1 to 100 do if (i mod 3 = 0) then s:=s+i;

writeln('Сумма чисел, которые делятся на 3: ',s);

readln;

end.


Выбирайте на свой вкус

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота