Ajosha
07.09.2021 05:27

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. пример: введите два числа: 10 -15 10*(-15)=-150 это цикл с условием ( while) паскаль заранее

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lermolen
09.10.2020 06:24

javascript:var a = parseInt(prompt()), b = parseInt(prompt()), c = 0, сч = 0; while (сч < Math.abs(b)) { c += a; сч++; } if (b < 0) c = -c; alert(c);


А вот и Pascal. Надеюсь, не ошибся.


program pr;

var a, b, c, cnt: integer;

begin

 a := readln();

 b := readln();

 c := 0;

 cnt = 0;

 while (c < abs(b)) begin

   c := c + a;

   cnt := cnt + 1;

 end;

 writeln(c);

end.

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота