plisetskayakatoy4che
24.01.2023 04:01

Написать программу на с++, используя функции. найти наименьшее общее кратное четырех заданных натуральных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lizaveta9999
17.08.2020 01:54

#include <iostream>

#define _ std::

int NOD(int a, int b){

return (a == 0) ? b : NOD(b%a, a);

}

int NOK(int a, int b) {

return (a*b) / NOD(a, b);

}

int main() {

int a, b, c, d;

_ cin >> a >> b >> c >> d;

_ cout << NOK(a, NOK(b, NOK(c, d))) << _ endl;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота