kyrmaeva200614
09.10.2021 13:47

Решить на с++ напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них. числа — целые от 1 до 1000. при решении можно пользоваться только целочисленными арифметическими операциями +, -, *, //, %, =. нельзя пользоваться нелинейными конструкциями: ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня. примеры: вход: 8 5 вывод: 8 вход : 5 8 вывод: 8 вход: 5 5 выход: 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nastyaozernova
09.10.2020 05:06

#include <iostream>

int main()

{

int a, b;

std::cin >> a >> b;

std::cout << (a*(a / b) + b * (b / a)) / (b / a + a / b) << std::endl;

   return 0;

}


Главное 0 не вводите :)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота