katystolbova
10.03.2020 06:21

Составьте программу, которая вычисляет произведение чисел от 1 до n. число n вводится с клавиатуры. с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
school712
09.10.2020 04:59
Код

#include <iostream>

using namespace std;

int main()

{

   // 1*2*3*4*5*6*7*8*9*10 = 3628800

   setlocale(LC_ALL, "Russian");

   unsigned int N;

   long long int Result = 1;

   cin >> N;

    for(int i = 1; i <= N; i++){

       Result = Result * i;

   }

   cout << endl << Result;

   return 0;

}

Проверка

10

3628800


5

120

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота