асел9
27.05.2022 01:54

Написать программу, запрашивающую пять чисел и суммирующию только положительные из них. значение суммы вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SaharaYo
09.10.2020 04:34

uses crt;

const n=5;

var a:array[1..n] of integer;

   s,i:integer;

begin

    for i:=1 to n do

    read(a[i]);

    for i:=1 to n do

    write(a[i]:3);

    for i:=1 to n do

    begin

         if (a[i]>0)and(a[i]<>0) then s:=s+a[i];

    end;

    writeln;

    write(s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота