Eugene1223
28.12.2020 18:26

Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она находила количество чётных, нечётных и среднее арифметическое. это всё в одной программе.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Сахарокcom
09.10.2020 04:10

var a:array [1..10] of integer;

i,k1,k2,s1,s2:integer;

begin

for i:= 1 to 10 do

a[i]:= Random(100);

writeln(a);

for i:=1 to 10 do

begin

if a[i] mod 2 = 0 then

begin

k1:=k1+1;

s1:=s1+a[i]

end

else

begin

k2:=k2+1;

s2:=s2+a[i]

end

end;

writeln('Количество чётных элементов: ',k1);

writeln('Количество не чётных элементов: ',k2);

writeln('Cреднее арифметическое чётных элементов: ',s1/k1);

writeln('Cреднее арифметическое не чётных элементов: ',s2/k2);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота