viktorvipp0aa6w
06.12.2020 04:52

Составьте программу с условием if. ввести а и в. если аменьшев в квадрате, то x=a*под корнем в. иначе y=acosb. вывести на экран либо x, либо y
10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gesse99
08.01.2023 11:21

Задача А

program Boom;

uses crt;

var

 a, b: integer;

begin

 Read(a, b);

 if a > b then Writeln('Наибольшее число ', a) else Writeln('Наибольшее число ', b);

end.

Тестовое решение

12

52

Наибольшее число 52

Задача Б

program Boom;

uses crt;

 

var

     a:array[1..4] of Integer;

     max:integer;

     i:byte;

Begin

for i:= 1 to 4 do

Begin

Write('Введите число:');

Read(a[i]);

End;

max := a[1];

for i:= 2 to 4 do

if a[i] > max then

max := a[i];

Write('Наибольшее число:');

WriteLn(max);

End.

Тестовое решение:

Введите число:12

Введите число:53

Введите число:34

Введите число:63

Наибольшее число:63

0,0(0 оценок)
Ответ:
AZIMJON11
11.03.2023 08:06

while True:

   n = int(input('ввести конечное число n '))

   answ = ''

   if n<=10:

       print("число должно быть больше 10")

   else:

       for i in range(10,n):

           answ = ''

           for j in str(i):

               answ+=j

           for b in range(len(answ)):

               if b>0:

                   if answ[b]!=answ[b-1]:

                       break

                   if b==len(answ)-1 and answ[b]==answ[b-1]:

                       print(answ)

   

Всегда выполнять

Ввод числа

Переменная ответ для его вывода

Проверка числа(больше ли оно 10)

Если больше

от 10 до n раз

аннулируем ответ

записываем в него число

от 0 до длинны числа

если элемент не первый

проверяем его, совпадает ли он с предыдущим

если нет, заканчиваем проверять, ибо цифры уже не все одинаковые

если проверили последнее число и всё совпадает, выводим ответ

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота