dedada
11.08.2020 03:01

3. напишите программу. известны данные о расходе электро-
энергии n предприятиями отрасли за год. определите сред-
ний расход электроэнергии по отрасли.
для n 10 запишите исходные данные и полученный ре-
зультат:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Инна1234432114865
28.06.2021 07:04

/*

Выводы перед вводом данных(cout) можно убрать (сделал для удобства)

*/

#include <iostream>

#include <vector>

#define UNITS '$' // <- Валюта

using namespace std;

int main()

{

   int SWEETS, COOKIES, APPLES;

   cout<<"Price for 1 kg of sweets\n>>"<<UNITS;

   cin>>SWEETS;

   cout<<"Price for 1 kg of cookies\n>>"<<UNITS;

   cin>>COOKIES;

   cout<<"Price for 1 kg of apples\n>>"<<UNITS;

   cin>>APPLES;

   int x, y, z;

   cout<<"Enter amount in kg\n";

   cout<<"How many sweets?\n>>";

   cin>>x;

   cout<<"How many cookies?\n>>";

   cin>>y;

   cout<<"How many apples?\n>>";

   cin>>z;

   int total = x*SWEETS + y*COOKIES + z*APPLES;

   cout<<"\n"<<"TOTAL PRICE IS\n"<<UNITS<<total<<"\n\n";

   return 0;

}

0,0(0 оценок)
Ответ:
20051207маша
28.06.2021 07:04

1:

print(hex(int(input()))[2:].upper())

Объяснение:

int(input()) ввод числа

hex(x) перевод числа из 10 в 16 с.с. в таком виде 15(10) -> 0xf(16)

[2:] отсекает первые два символа(0x)(просто знай, что они не нужны)

.upper() метод строки, делающий из f -> F

2-ое задание это часть 3-его, поэтому код один и тот же:

alphabet = ''

def now_system_10(x):

   global new_system

   znak = '+'

   if x < 0:

       x = abs(x)

       znak = '-'

   new_x = ''

   lst = []

   while x >= new_system or lst == []:

       if 9 < x % new_system:

           if x % new_system < 20:

               lst += [alphabet[int(str(x % new_system)[1])]]

           elif x % new_system < 30:

               lst += [alphabet[int('1' + str(x % new_system)[1])]]

           else:

               lst += [alphabet[int('2' + str(x % new_system)[1])]]

       else:

           lst += [x % new_system]

       x //= new_system

   if x != 0:

       lst += [x]

   lst.reverse()

   if znak == '-':

       new_x += '-'

   for j in lst:

       new_x += str(j)

   return new_x

num, new_system = map(int, input().split())

print(now_system_10(num))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота