Msrisel
03.06.2023 13:28

Написать программу, которая проверяет, принадлежит ли точка (x,y) закрашенной области (x,y и r вводится пользователем)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
аня2934
29.09.2019 06:10

pascalabc:

program f0rwardirop;

var r, x,y: real;

b: boolean;

begin

  writeln('*   alphaeus is   *');

  write('ok, введите r =');   readln(r);

  write('теперь введите х =');   readln(x);

  write('и, наконец, введите y =');   readln(y);

  if x> =0 then  

      if (x*x+y*y < = r*r) then b: = true else b: =false

    else

      if (abs(x) < =r) and (abs(y) < =r) and (abs(x) < = abs(y)) then b: = true else b: =false;

  if b then   writeln('точка (',x,',',y,') принадлежит закрашенной области')

      else   writeln('точка (',x,',',y,') не принадлежит закрашенной области');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота