romashka1899
10.03.2020 09:17

Вариант 1
1. напишите программу. одномерный массив а[1..n] заполнен
0 и 1, расположенными в произвольном порядке. перефор-
мируйте массив так, чтобы сначала шли элементы, равные
0, а затем — 1. предусмотрите вывод исходного и перефор-
мированного массивов на экран.
запишите текст программы:
- - - - - - - - - - - - - -
-
- - - - - - - - - - -

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
раф15рус
09.10.2020 01:25

var A:array[1..100000] of integer; i,k,i1,n:int64;

 begin

read(n);

 randomize;

  for i:=1 to n do

     A[i]:=random(2);

 writeln('Массив до переформировки:');

    for i:=1 to n do  

     write(A[i],' ');

 writeln;

 

for i1:= 1 to n do

 for i:=1 to n-1 do

   if A[i]>A[i+1] then begin k:=A[i]; A[i]:=A[i+1]; A[i+1]:=k; end;

     

     writeln('Массив после переформировки:');

    for i:=1 to n do  

     write(A[i],' ');

       

      end.

   

     

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота