Дженнa
30.04.2023 16:00

Написать программу c# решения квадратного уравнения ax^2+bx+c=0 программа должна проверять правильность исходных данных и в случае, когда коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение. тест: исходные данные: a = 1, b= -3, c= 2 результат : х1=2 х2=1

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MN1k1ta
09.10.2020 01:13

using System;


namespace Test

{

   class Program

   {

       static void Main(string[] args)

       {

           double a, b, c;

           a = Double.Parse(Console.ReadLine());

           b = Double.Parse(Console.ReadLine());

           c = Double.Parse(Console.ReadLine());


           double D = b * b - 4.0 * a * c;


           if (a == 0.0)

           {

               double x = -c / b;

               Console.WriteLine("X = {0}", x);

           }

           else

           if (b == 0.0 && -c / a > 0.0)

           {

               double x1 = Math.Sqrt(-c / a);

               double x2 = -Math.Sqrt(-c / a);


               Console.WriteLine("X1 = {0}, X2 = {1}", x1, x2);

           }

           else

           if (D == 0.0)

           {

               double x = -b / (2.0 * a);

               Console.WriteLine(x);

           }

           else

           if (D > 0.0)

           {

               double x1 = (-b - Math.Sqrt(D)) / (2.0 * a);

               double x2 = (-b + Math.Sqrt(D)) / (2.0 * a);


               Console.WriteLine("X1 = {0}, X2 = {1}", x1, x2);

           }

           else

           {

               Console.WriteLine("D < 0, корней нет");

           }


           Console.ReadKey();

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота