Klamie
25.01.2020 21:02

Нужно составить программу, которая будет отвечать на вопрос является ли число степенью двойки.заранее

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lenusyamailru
11.08.2020 08:26

#include <stdio.h>

#include <stdlib.h>


int main()

{

int number;

scanf("%d", &number);

number = abs(number);

if(number % 2 != 0)

{

 printf("Не является!");

 return 0;

}

while(number > 2)

{

 number /= 2;

}

if(number == 2)

 printf("Является!");

else printf("Не является!");

}


Нужно составить программу, которая будет отвечать на вопрос является ли число степенью двойки.заране
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота